mercredi 30 janvier 2013

Windows Phone 8 (WP8) Emulator problems - Virtual switch error (french)

Mise à jour

Bonjour tous,

Suite à cet article, j'ai voulu continuer mon projet WP8. A ma grande surprise, il ne m’était plus possible de lancer l’émulateur WP8!!!

Bon, au lieu de continuer à lutter, je me suis lancer dans une réinstallation de mon Windows 8 (pfffff c'est lourd). Heureusement, Microsoft permet une réinstallation (selon eux) plus aisée sans avoir à utiliser de média (je répété, selon eux)
Voici un article exposant la procédure à suivre.

Apres plusieurs tests, je me rend compte que mon problème vient d'AVAST! 7 internet security.
Pour une raison qui m'est toujours obscure, le firewall bloque toute création de virtual switchs, que ce soit pour WP8 ou pour tout autre machine virtuelle.

Solution

Soit désinstaller Avast! internet security et le réinstaller en supprimant le firewall

Bon travail à tous!

-----------------------------------------------------------------------------------------------

Salut,

Voici un problème sur lequel je suis tombé en voulant tester ma première application WP8.
Je lance l'emulateur, celui-ci me donne plusieurs message d'erreurs:

le 1er



une fois cliqué sur le boutton "retry", une second message s'affiche

Ça prend un peu de temps mais pour finir, j'ai ce troisième message

Impossible donc de déployer mon application sur l’émulateur (génial :-( )


Quelques recherche sur le net et voila les pistes qui m'ont permis de résoudre:

Tout d'abord, vérifiez que vous n'avez pas de connections VPN ou même un autre système de machines virtuelles (VMware par exemple) si oui, malheureusement, il faudra les désinstaller.

Là, les choses deviennent de plus en plus compliquées:

il y a quelques articles en anglais essayant de guider vers une solution, voici les liens:
http://social.msdn.microsoft.com/Forums/en-US/wptools/thread/1734dac7-37a4-4d9a-bf89-42b6d493adda
http://stackoverflow.com/questions/13149509/windows-phone-8-emulator-error-something-happened-while-creating-a-switch

Mais rien n'a marché.

La solution la plus simple fut de re-installer le SDK WP8 avec la fonction "repair",  tout de même un plantage en fin d’opération.
Mais ça fonctionne.

Rien d’inédits, mais j'y ai quand même passé 4h a tout tester avant de décider de réinstaller. Si ça peut vous permettre d'y passer moins de temps.

Bon travail à tous!




Aucun commentaire:

Publier un commentaire